Fossil

Check-in [e2426e83]
Login

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview
Comment:Fix an incorrect comment in sqlcompattest.c.
Downloads: Tarball | ZIP archive | SQL archive
Timelines: family | ancestors | descendants | both | trunk
Files: files | file ages | folders
SHA3-256: e2426e83e417c1120d22d5f2a3ef2e941499ab7d1e6591e80da2e6b6ba141528
User & Date: drh 2019-08-07 12:49:23
Context
2019-08-07
12:55
Remove the SQLITE_ENABLE_DBPAGE_VTAB requirement from external SQLite libraries, as without it only the ".recover" command in "fossil sql" is omitted, and that is an obscure case. check-in: a4d71525 user: drh tags: trunk
12:49
Fix an incorrect comment in sqlcompattest.c. check-in: e2426e83 user: drh tags: trunk
12:45
Fix incorrect requirements in sqlcompattest.c. check-in: 156476b2 user: drh tags: trunk
Changes
Hide Diffs Unified Diffs Ignore Whitespace Patch

Changes to src/sqlcompattest.c.

40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
*/
#include "sqlite3.h"
#include <stdio.h>

int main(int argc, char **argv){
  int i;
  static const char *zRequiredOpts[] = {
    "ENABLE_FTS4",         /* Required for repository search */
    "ENABLE_JSON1",        /* Required for the check-in locking protocol */
    "ENABLE_DBSTAT_VTAB",  /* Required by /repo-tabsize page */
    "ENABLE_DBPAGE_VTAB",  /* Required by the .dump command in "fossil sql" */
  };

  /* Check minimum SQLite version number */
  if( sqlite3_libversion_number()<3028000 ){
    printf("found SQLite version %s but need 3.28.0 or later\n",
            sqlite3_libversion());
    return 1;







|
|
|
|







40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
*/
#include "sqlite3.h"
#include <stdio.h>

int main(int argc, char **argv){
  int i;
  static const char *zRequiredOpts[] = {
    "ENABLE_FTS4",        /* Required for repository search */
    "ENABLE_JSON1",       /* Required for the check-in locking protocol */
    "ENABLE_DBSTAT_VTAB", /* Required by /repo-tabsize page */
    "ENABLE_DBPAGE_VTAB", /* Required by the .recover command in "fossil sql" */
  };

  /* Check minimum SQLite version number */
  if( sqlite3_libversion_number()<3028000 ){
    printf("found SQLite version %s but need 3.28.0 or later\n",
            sqlite3_libversion());
    return 1;